Florida Medicaid SKFL0 and 12K34 - ERA Enrollment Delay

Incident Report for Optum OKC Clearinghouse

Update

Update: Change Healthcare is pending changes at Florida Medicaid to allow Claims Enrollment and Electronic Remittance Advice (ERA) enrollments. An update will be provided once the issue is resolved.

Original message:

Change Healthcare has identified an issue that is preventing new ERA enrollments with Florida Medicaid for the below payer IDs:

• SKFL0 Florida Medicaid
• 12K34 - Florida Medicaid

Change Healthcare is working with the payer to resolve this issue.

Providers can download ERAs directly via their Florida Medicaid Web Portal account. If further assistance is required, please contact Florida Medicaid provider support team with your 9-digit Medicaid ID directly at FLEDITEAM@gainwelltechnologies.com.

Additional updates will be forwarded as more information becomes available.

Action Required: Please be aware of a delay in enrolling for ERA delivery through Change Healthcare for the above payer IDs.

If you have any questions, feel free to contact your Customer Support.

REF 554950, 567850
Posted Sep 08, 2023 - 18:07 EDT

Identified

Correction: This situation is ongoing and was marked resolved in error.

Original Message:

Change Healthcare has identified an issue that is preventing new ERA enrollments with Florida Medicaid for the below payer IDs:

• SKFL0 Florida Medicaid
• 12K34 - Florida Medicaid

Change Healthcare is working with the payer to resolve this issue.

Providers can download ERAs directly via their Florida Medicaid Web Portal account. If further assistance is required, please contact Florida Medicaid provider support team with your 9-digit Medicaid ID directly at FLEDITEAM@gainwelltechnologies.com.

Additional updates will be forwarded as more information becomes available.

Action Required: Please be aware of a delay in enrolling for ERA delivery through Change Healthcare for the above payer IDs.

If you have any questions, feel free to contact your Customer Support

REF: 554950

As you may know, Change Healthcare is becoming part of Optum. Throughout the brand migration process, both brand identities may be visible in our markets.
Posted Aug 23, 2023 - 15:59 EDT
This incident affects: Institutional and Professional.