This is an update on an issue previously reported by Optum.
Optum has worked with MassHealth and have been able to resolve the issue with delivering claim files and receiving 999 responses. All files that were previously backlogged due to this issue have now been successfully delivered to the payer.
The resolution to the ERA delivery issue is still being reviewed. Optum will be able to confirm that change worked after the next release of ERA by the payer.
Once that is completed, another communication will be sent out.
Posted Feb 07, 2024 - 16:34 EST
Identified
Optum identified an interruption to normal claims delivery with MassHealth, Payer IDs 12K14 and SKMA0, related to claims processed at Optum after Jan. 14, 2024. This resulted in some processing delays for the impacted claims.
Optum is working closely with the payer to resolve this issue as soon as possible.
REF 658651
Posted Jan 26, 2024 - 17:35 EST
This incident affects: Institutional and Professional.